configure


※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

./configure したときにエラーが出る時がありますが、
何を入れたらいいか分かりづらい時があるのでメモ。
(検索は $ apt-cache search gtk-sharp など)

vineのセットアップCDには開発パッケージは含まれていないので、
# apt-get script install-devel.lua
でまとめてインストールした方が楽かも。

No package 'libmusicbrainz' found
  • > $ sudo apt-get install libmusicbrainz-devel


No package 'dbus-1' found
  • > $ sudo apt-get install dbus-devel


checking wxWidgets version... ./configure: line 1: wx-config: command not found not found
  • > $ sudo apt-get install wx-gtk2-devel


configure: error: unable to use zlib - no peer found
  • > $ sudo apt-get install zlib-devel


checking for wx-config... no
  • > $ sudo apt-get install wx-gtk2-devel して、# /sbin/ldconfig


g+: /usr/lib/libidn.so: No such file or directory
  • > $ sudo apt-get install libidn-devel


No package 'pangoft2' found
  • > $ sudo apt-get install pango-devel


No package 'gtkmm-2.4' found
  • > $ sudo apt-get install gtkmm2-devel


No package 'libglademm-2.4' found
  • > $ sudo apt-get install libglademm2-devel


libtool: link: cannot find the library '/usr/lib/libfam.la'
  • > $ sudo apt-get install fam-devel


libtool: link: cannot find the library '/usr/lib/libjpeg.la'
  • > $ sudo apt-get install libjpeg-devel


configure: error: The important program mcopidl was not found!
  • > $ sudo apt-get install arts-devel


checking for libz... configure: error: not fount.
  • > $ sudo apt-get install libzvt-devel


configure: error: You need to install the Mono runtime
  • > $ sudo apt-get install mono-devel


No package 'gconf-sharp-2.0' found
(beagle)


No package 'glib-2.0' found
  • > $ sudo apt-get install glib2-devel

No package 'gtk+-2.0' found
  • > $ sudo apt-get install gtk2-devel


No package 'libglade-2.0' found
  • > $ sudo apt-get install libglade2-devel


No package 'libgnome-2.0' found
  • > $ sudo apt-get install libgnome-devel


checking for kde-config... configure: error:
  • > $ sudo apt-get install kdelibs-devel


checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!
  • > $ sudo apt-get install kdelibs-devel

No package 'mono' found
  • > $ sudo apt-get install mono-devel

No package 'libexif' found
  • > $ sudo apt-get install libexif-devel

No package 'gtk+-2.0' found
  • > $ sudo apt-get install gtk2-devel

No package 'librsvg-2.0' found
  • > $ sudo apt-get install librsvg2-ddevel

No package 'gnome-vfs-2.0' found
  • > $ sudo apt-get install gnome-vfs2-devel

No package 'libgnome-2.0' found
  • > $ sudo apt-get install libgnome-devel

checking for SQLITE... checking for SQLITE3... configure: error: You need to install sqlite 2.x or >= 3.3.1
  • > $ sudo apt-get install sqlite3-devel

checking for GTK - version >= 1.2.0... no
  • > $ sudo apt-get install gtk+-devel

No package 'gtk-sharp-2.0' found
  • > $ sudo apt-get install gtk-sharp2

configure: error: You need to install gtk-sharp2-gapi
  • > $ sudo apt-get install gtk-sharp2-gapi

checking for Mono.Data.SqliteClient.dll... configure: error: missing required mono DLL: Mono.Data.SqliteClient.dll
  • > $ sudo apt-get install mono-data-sqlite

checking for System.Web.dll... configure: error: missing required mono DLL: System.Web.dll
  • > $ sudo apt-get install mono-web

checking for SQLITE... checking for SQLITE3... configure: error: You need to install sqlite 2.x or >= 3.3.1
  • > $ sudo apt-get install sqlite-devel

No package 'gtk+-2.0' found
  • > $ sudo apt-get install gtk2-devel

No package 'librsvg-2.0' found
  • > $ sudo apt-get install librsvg2-devel

No package 'libexif' found
  • > $ sudo apt-get install libexif-devel

No package 'gmime-2.0' found
  • > $ sudo apt-get install gmime-devel

checking for mono.pc... configure: error: missing the mono.pc file, usually found in the mono-devel package
  • > $ sudo apt-get install mono-devel

checking for Mono.Data.SqliteClient.dll... configure: error: missing required mono 2.0 DLL: Mono.Data.SqliteClient.dll
  • > $ sudo apt-get install mono-data-sqlite

checking for System.Runtime.Remoting.dll... configure: error: missing required mono 2.0 DLL: System.Runtime.Remoting.dll
  • > $ sudo apt-get install mono-web

configure: error: You need to install the Mono runtime
  • > $ sudo apt-get install mono-devel

checking for System.Data.dll... configure: error: missing required mono DLL: System.Data.dll
  • > $ sudo apt-get install mono-data


make[1]: /bin/uic: コマンドが見つかりませんでした



libtool: link: warning: library `/usr/lib/libORBit.la' was moved.
ツールボックス

下から選んでください:

新しいページを作成する
ヘルプ / FAQ もご覧ください。